java runtime class file version 61.0

При установке пакетов в Qt Creator для Android  SDK packages через SDK Manager возникла ошибка:

java runtime class file version 61

Error LinkageError occurred while loading main class com.android.sdklib.tool.sdkmanager.SdkManagerCIijava.lang.UnsupportedClassVersionError com/android/sdklib/tool/sdkmanager/SdkManagerCIi has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 55.0

Ошибка говорит о том, необходимо установить версию 61.0 вместо 55.0 версии Java, то есть необходимо скачать и установить Java 17, вместо Java 11 и заново указать путь для JDK — в настройках Android размещение JDK.

Размещение JDK


Таблица версий и номеров Java

Версия Java Номер версии Java
JDK 49 Java 5
JDK 50 Java 6
JDK 51 Java 7
JDK 52 Java 8
JDK 53 Java 9
JDK 54 Java 10
JDK 55 Java 11
JDK 56 Java 12
JDK 57 Java 13
JDK 58 Java 14
JDK 59 Java 15
JDK 60 Java 16
JDK 61 Java 17
JDK 62 Java 18
JDK 63 Java 19
JDK 64 Java 20
JDK 65 Java 21
226

Leave a Reply

Ваш адрес email не будет опубликован.