Симплекс-метод решения задачи линейного программирования в Excel

Рассмотрим решение задачи линейного программирования с помощью симплекс-метода в Excel на примере

Целевая функция имеет вид
Z = 35∙x1+25∙x2+10∙x3+20∙x4→ max
Ограничения, записанные в виде системы линейных уравнений

4∙x1+1∙x2+2∙x3+0∙x4 ≤ 120
1∙x1+3∙x2+1∙x3+1∙x4 ≤ 160∙
2∙x1+1∙x2+1∙x3+3∙x4 ≤ 130
x1, x2, x3, x4 ≥ 0 – целые

Теперь данную задачу для решения запишем в ExcelПример задачи линейного программирования в Excel

отображение формул

В ячейке E4 вставим формулу
=A4*A5+B4*B5+C4*C5+D4*D5

Для ячейки E7, E8 и E9 формула будет иметь вид

=$A$4*A7+$B$4*B7+$C$4*C7+$D$4*D7
=$A$4*A8+$B$4*B8+$C$4*C8+$D$4*D8
=$A$4*A9+$B$4*B9+$C$4*C9+$D$4*D9

Также можно воспользоваться формулой:
=СУММПРОИЗВ(A4:D4;A7:D7)

На вкладке данные переходим в Поиск решения

Выбираем ячейку с целевой функцией, ставим галочку максимум, далее выбираем ячейки изменяемых переменных ($A$4:$D$4) и добавляем ограничения при помощи кнопки Добавить. Также ставим галочку переменные без ограничений неотрицательные, выбираем, выбираем метод решения – симплекс-метод решения линейных задач.

симплекс-метода в Excel поиск решения линейной задачи

Ограничения больше меньше или равно Excel Ограничения для целых чисел Excel

Можно также перейти в параметры и настроить точность.

Параметры точности симплекс метода
Итак, нажимаем Найти решение, появляется окно результаты поиска решений, выбираем сохранить найденное решение.

Результат поиска решения Excel

В итоги получили решения задачи

Z=2015
x1=19; x2=42; x3=0; x4=15

Результат решения задачи симплекс методом в Excel

Leave a Reply

Ваш e-mail не будет опубликован.