Решение транспортной задачи в Excel

Решим транспортную задачу в Excel.

Условие транспортной задачи приведено в виде таблицы в Excel

 Транспортная задача условие Excel

Затем для решения данной задачи ниже исходной создадим вспомогательную таблицу.

Вспомогательная таблица Excel

Далее

в диапазон ячеек H13:H17 запишем ограничения вида:

=F3

=F4

=F5

=F6

=F7

в диапазон ячеек B8:E8 запишем ограничения:

=B8

=C8

=D8

=E8

в диапазон ячеек F13:F17 запишем формулы суммы по строкам:

=СУММ(B13:E13)
=СУММ(B14:E14)
=СУММ(B15:E15)
=СУММ(B16:E16)
=СУММ(B17:E17)

в диапазон ячеек F13:F17 формулы суммы по столбцам:

=СУММ(B13:B17)
=СУММ(C13:C17)
=СУММ(D13:D17)
=СУММ(E13E17)

Затем в ячейки F22 (целевая функция) запишем формулу суммы произведения:

=СУММПРОИЗВ(B3:E7;B13:E17)

В итоги в Excel должна получиться следующая таблицаExcel решение транспортной задачи

с формулами
Excel формулы

Затем переходим на вкладку Данные -> Поиск решения

Поиск решения Excel

В параметре поиска решений задаём

Оптимизировать целевую функцию — задаем ячейку F22

Выбираем минимум

Изменяемые ячейки переменных — задаем диапазон ячеек $B$13:$E$17

Ставим галочку — сделать переменные без ограничений неотрицательными и выбираем метод решения — поиск решения задач симплекс-методом линейного программирования.

Затем нажимаем на кнопку Добавить и задаем ограничения
Параметры поиска решения

Ограничения по строкам и нажимаем Добавить

ограничения по строкам Excel

Ограничения по столбцам и нажимаем Добавить

ограничения по столбцам Excel

Задаем также целочисленные ограничения и нажимаем Добавить и Ок

целочисленные ограничения

Можно также зайти в параметры и настроить точность по желанию, нажимаем Ок.

Параметры

Окно параметров поиска решения транспортной задачи и нажимаем Найти решение

Параметры поиска решения транспортной задачи в Excel

Итак на листе Excel появятся решения, а также окно с результатами поиска решений, здесь можно выбрать Сохранить найденное решение и нажать Ок.

 Сохранить найденное решение

Итак, целевая функция равна 5840.

Распределение запасов 

распределение запасов

Итак общее решение транспортной задачи в Excel имеет видРешение транспортной задачи в Excel таблица

Leave a Reply

Ваш e-mail не будет опубликован.